wdrożenia PrestaShop Powiększenie zdjęć moduł wdrożenia PrestaShop

CVE-2012-1823 - Dziura PHP w trybie CGI

  • 0 Odpowiedzi
  • 2609 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline sower

  • Mieszkaniec
  • *****
  • 1,016
  • 3
    • I Love PrestaShop
  • Presta Shop: PS
  • Status: Programista
CVE-2012-1823 - Dziura PHP w trybie CGI
« dnia: Maj 07, 2012, 06:13:07 pm »
CVE-2012-1823 - Dziura PHP w trybie CGI

W ostatnich dniach został upubliczniony exploit wykorzystujący lukę w zabezpieczeniach komunikacji między PHP a CGI.

CGI i PHP komunikują się między sobą umożliwiając na zdalne uruchomienie kodu na serwerze a by było ciekawiej błąd ten istnieje od około 8 lat ;).

Ponatność na ataki wynika z tego, iż interpreter PHP nie jest do końca zgodny za wytycznymi standardu CGI i czasem parametry URL mogą zostać przekazane do interpretara PHP i zinterpretowane jako argumenty linii poleceń.

Tu mała uwaga - powyższa dziura występuje na  serwerach  z PHP pracujących w trybie CGI, instalacje z FastCGI PHP nie są podatne na ten atak.

Więcej informacji:

http://people.canonical.com/~ubuntu-security/cve/2012/CVE-2012-1823.html

https://bugs.php.net/bug.php?id=61910


Niestety w naszym kraju jest sporo serwerów, które posiadają w/w dziurę - (szczególnie VPS i dedyków) - dlatego udostępniliśmy moduł dla PRESTY 1.4, który pozwoli sprawdzić czy serwer, na którym pracuje sklep jest podatny na atak przy wykorzystaniu w/w dziury.

Moduł do pobrania: http://delf.biz.pl/pl/blog/nowosci/5-dziura-w-php-tryb-cgi-cve-2012-1823.html
SZYBKA POMOC TECHNICZNA : gg 45116037
SKLEPY | MODUŁY | INTEGRACJE | POMOC TECHNICZNA