wdrożenia PrestaShop Powiększenie zdjęć moduł

dla osob instalujacych PS na home.pl

  • 38 Odpowiedzi
  • 31536 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline cloudsky

  • Tubylec
  • ****
  • 124
  • 0
    • Ekskluzywna odziez i dodatki...
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #15 dnia: Wrzesień 02, 2010, 08:00:27 am »
co do logowania to jakos udało mi się to obejść i już nie mam żadnego z tym problemu na home.pl
po prostu usunałem dalsza sciezke z paska adresu /admin../index.php... usunałem tą cześć i zostawilem tyko /admin i jakos od tej pory sie loguje bez problemu.

Ale ciągle mam problem z tym
Path is not the same between your browser and you server

po zastosowaniu porad z forum udało mi sie usunąc tylko ten problem po stronie serwera, ale po stronie przegladarki nadal mi sie to pojawia...

*

Offline kubam

  • Nowy
  • *
  • 4
  • 0
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #16 dnia: Listopad 17, 2010, 05:44:50 pm »
Witam przy imporcie dużej bazy z obrazkami pokazuje mi się błąd:

ABORT: PHP cpu time limit exceeded in imagejpeg() called at [/images.inc.php:238], in
returnDestImage() called at [/images.inc.php:162], in imageResize() called at [/panel
/tabs/AdminImport.php:395], in AdminImport::copyImg() called at [/panel/tabs/AdminImport.php:749], in
AdminImport::productImport() called at [/panel/tabs/AdminImport.php:1435], in
AdminImport::postProcess() called at [/panel/index.php:61]
 

Baza 5000 produktów. A importuje tylko 290.

Pewnie jakaś blokada czasowa dla skryptu. Albo inny błąd.
Jak to ominąć? Może macie jakieś rozwiązania?

*

Offline olinek

  • Nowy
  • *
  • 4
  • 0
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #17 dnia: Luty 25, 2011, 08:16:16 am »
w jaki sposób ostatecznie ustawić to SMTP żeby działało? ja po ustawieniu danych i próbie wysłania maila z formularza kontaktowego otrzymuję błąd wysyłki :(
U mnie problemy z wysyłaniem maili poprzez SMTP jak również problemy z "białą kartą" podczas wyświetlania historii zamówień klienta, dodawanie atrybutów, cech i innych w produktach (zakładki od 3 do 7 w edycji produktu) zniknęły po wyłączeniu opcji statystyk w moim koncie na serwerze home.pl Okazało się, że automatycznie wstawiany fragment kodu w skrypcie statystyk kolidował ze skryptem presty i blokował pewne funkcje. Na pewno nie odpowiada to za większość błędów, ale akurat te udało mi się w ten sposób wyeliminować.
Pozdrawiam
Piotr

*

Offline klima

  • Nowy
  • *
  • 2
  • 0
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #18 dnia: Maj 04, 2011, 11:13:39 pm »
Wina nie lezy tylko po stronie home.pl ale rowniez wynika z niedopasowania ustawien cms do ustawien serwera na home.pl szukajac winy nielogowania za pierwszym razem w pliku authentication.php
dodalem w liniach 8 i 9 zamiast
if ($cookie->isLogged())
   Tools::redirect('my-account.php');\


if ($cookie->isLogged())
   Tools::redirect('my-account.php');
else echo "<h>NIEZALOGOWANY</h1>\n";

i logouje odrazu
doszlismy do wniosku ze moze to byc wina cache serwera
po sprawdzeniu snifferem bez tego echo serwer nie dolacza naglowka z przekierowaniem na strone my-account.php mozne trzeba wymusic wyyslanie tych naglowkow

*

Offline anna ag

  • Nowy
  • *
  • 2
  • 0
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #19 dnia: Maj 13, 2011, 08:37:12 am »
Drodzy forumowicze,
chciałabym podziekować za wszelkie rady zamieszczone na tym forum. Wybrałam to miejsce bo buduję sklep na home.pl. Wszystko śmiga na preście 1.4 polska wersja. Korzystam z darmowego maila na gmailu.

Na home ustawiłam sobie subdomenę z przekierowaniem na katalog /sklep (domena główna wskazuje na folder /kreator gdzie mam całą resztę strony) bo inaczej automatycznie mnie przekierowywało na stronę główną ze sklepu.

Wrzucając pliki presty na ftp katalog sklep, korzystałam z filezilla, przesył binarny.

Założyłam folder /tmp z uprawnieniami777 w folderze mojego sklepu - dodają się zdjęcia produktu.

ustawiłam smtp (port 465, kodowanie SSL) (są na to rady w wielu innych wątkach)- wysyłają się maile na gmail i wp.

Faktycznie czasem nie zawsze od razu po ustawieniu pokazują się wszystkie nowe opcje (np. nie od razu można wybrać w sklepie wszystkich nowododanych dostawców) ale przecież internet też musi się chwile zastanowić.

Po prawidłowym zalogowaniu administratora wyrzuca mi że nie ma takiej strony więc wpisuję znowu adres sklepu z końcówką admina i okazuje się że jestem zalogowana. nie można mieć wszystkiego nie?

Mam włączone statystyki na home.pl a skrótów cms, php i smtp po prostu nie rozumiem :) Jednak powyższe rady brzmią bardzo profesjonalnie.

Dziękuję za wszystkie rady i życzę powodzenia w rozwiązywaniu dalszych problemów.

*

Offline dancone

  • Nowy
  • *
  • 1
  • 0
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #20 dnia: Wrzesień 05, 2011, 02:27:05 pm »
Witam,
Jak rozwiązać problem wgrywania zdjęć jeżeli instalacja jest w folderze /abcd, na który skierowana jest domena abcd.pl.
Problem dotyczy wgrywania zdjęć dla produktów, logo... itd.
Jeżeli wywołujemy operacje ze ścieżki http://user.home.pl/abcd pliki poprawnie wgrywają się.

Home.pl
PrestaShop 1.4.4.1.
tmp 777

Pozdrawiam
:-)

*

Offline zzxxcc

  • Nowy
  • *
  • 4
  • 0
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #21 dnia: Wrzesień 07, 2011, 07:42:49 pm »
Witam,
mam problem dotyczacy modulu PayPal. Mianowicie po dokonaniu zamowienia skrypt powinien przekierowac klienta na strone PayPal, a pojawia sie nastepujacy komunikat:

Cytuj
Malformed header from CGI script: * About to connect() to api-3t.paypal.com port 443 (#0) * Trying 66.211.168.126... * connected * Connected to api-3t.paypal.com (66.211.168.126) port 443 (#0) * successfully set certificate verify locations: * CAfile: /etc/ssl/certs/ca-certificates.crt CApath: none * SSL connection using DES-CBC3-SHA * Server certificate: * subject: C=US; ST=California; L=San Jose; O=PayPal, Inc.; OU=Information Systems; CN=api-3t.paypal.com * start date: 2009-09-24 00:00:00 GMT * expire date: 2011-09-19 23:59:59 GMT * issuer: C=US; O=VeriSign, Inc.; OU=VeriSign Trust Network; OU=Terms of use at https://www.verisign.com/rpa (c)09; CN=VeriSign Class 3 Secure Server CA - G2 * SSL certificate verify ok. > POST /nvp HTTP/1.1 Host: api-3t.paypal.com Accept: */* Content-Length: 679 Content-Type: application/x-www-form-urlencoded < HTTP/1.1 200 OK < Date: Wed, 07 Sep 2011 17:28:01 GMT < Server: Apache < Content-Length: 136 < Connection: close < Content-Type: text/plain; charset=utf-8 < * Closing connection #0 Status: 302 X-Powered-By: PHP/5.2.17 Content-Type: text/html; charset=utf-8 Set-Cookie: 8812c36aa5ae336c2a77bf63211d899a=HK7MjbLbw%2F8ogku%2BWY23ySr%2B%2BivP2Z3h62o8ocSpA66Gg4KgvACz84XQIF3gnrjKUc16xJFyXVEmafl2O0gn8ZMOs2Vn5wvoIj1ALFvfCcN%2BOILXxsZyXK5szM7zJbG2v5kypK1HagR5H06tDcWuhcDP3guB%2Fq3bkZb8imLvdVl0cmPHwR84%2BF%2FnMELAmicDHmYKPS0DE1Y1fc9fUZjNXwmIvpZBRHgMar9AkANJ3jXOvvS7aWjG39QKmprZvQwbxXwWYF330BtZxTAxIQvyDY5oewiZS99TGh%2BdZdOpWJkaCu68YKnOKUQJhp7NBRNwvyn2hDQv%2Bw0zNSPStzixFWxWAC%2FW6hJJtL%2FAnsQJ4xigkdPX5FFRdOoRSdx%2BdqmE%2BsFltsXmB18gWe0EkAD99s1IsVUghsYh41gyVVoNooE%3D000313; expires=Tue, 27-Sep-2011 17:27:59 GMT; path=/; domain=xxxxx.com; httponly Set-Cookie: 8812c36aa5ae336c2a77bf63211d899a=HK7MjbLbw%2F8ogku%2BWY23ySr%2B%2BivP2Z3h62o8ocSpA66Gg4KgvACz84XQIF3gnrjKUc16xJFyXVEmafl2O0gn8ZMOs2Vn5wvoIj1ALFvfCcN%2BOILXxsZyXK5szM7zJbG2v5kypK1HagR5H06tDcWuhcDP3guB%2Fq3bkZb8imLvdVl0cmPHwR84%2BF%2FnMELAmicDHmYKPS0DE1Y1fc9fUZjNXwmIvpZBRHgMar9AkANJ3jXOvvS7aWjG39QKmprZvQwbxXwWYF330BtZxTAxIQvyDY5oewiZS99TGh%2BdZdOpWJkaCu68YKnOKUQJhp7NBRNwvyn2hDQv%2Bw0zNSPStzixFWxWAC%2FW6hJJtL%2FAnsQJ4xigkdPX5FFRdOoRSdx%2BdqmEMmVxh8df23wKTUxJkToeRpjd6gaN4yPfqKZx89wGDL6%2FjM%2FmaKAEjsEVhHNfJLoH5R0fWrgm%2FDngdi0Ay%2FGsMQ%3D%3D000348; expires=Tue, 27-Sep-2011 17:27:59 GMT; path=/; domain=xxxxx.com; httponly Set-Cookie: 8812c36aa5ae336c2a77bf63211d899a=HK7MjbLbw%2F8ogku%2BWY23ySr%2B%2BivP2Z3h62o8ocSpA66Gg4KgvACz84XQIF3gnrjKUc16xJFyXVEmafl2O0gn8ZMOs2Vn5wvoIj1ALFvfCcN%2BOILXxsZyXK5szM7zJbG2v5kypK1HagR5H06tDcWuhcDP3guB%2Fq3bkZb8imLvdVl0cmPHwR84%2BF%2FnMELAmicDHmYKPS0DE1Y1fc9fUZjNXwmIvpZBRHgMar9AkANJ3jXOvvS7aWjG39QKmprZvQwbxXwWYF330BtZxTAxIQvyDY5oewiZS99TGh%2BdZdOpWJkaCu68YKnOKUQJhp7NBRNwvyn2hDQv%2Bw0zNSPStzixFWxWAC%2FW6hJJtL%2FAnsQJ4xigkdPX5FFRdOoRSdx%2BdqmEMmVxh8df23wKTUxJkToeRpjd6gaN4yPfqKZx89wGDL7Z48rpcWY7zL5X7cEcxn0ty6FbBlYNeUKnHpC570YOdq1%2Fw9BOcYCb%2BfL%2FkvhvEhyr0Ap550LCAYUkvq2LOckY000378; expires=Tue, 27-Sep-2011 17:27:59 GMT; path=/; domain=xxxxx.com; httponly Location: https://www.paypal.com/webscr&cmd=_express-checkout&token=EC-9BU739888S643073G&useraction=commit

Po skopiowaniu ostatniej frazy i wklejeniu jej do adresu przegladarki:
Cytuj
https://www.paypal.com/webscr&cmd=_express-checkout&token=EC-9BU739888S643073G&useraction=commit

Otwiera sie PayPal i mozna dokonac zaplaty.

Jak przerobic skrypt, aby otwarcie PayPala przebiegalo automatycznie?

Aktualny skrypt:

$useSSL = true;

include_once(dirname(__FILE__).'/../../../config/config.inc.php');
include_once(dirname(__FILE__).'/../../../init.php');

include_once(_PS_MODULE_DIR_.'paypal/paypal.php');
include_once(_PS_MODULE_DIR_.'paypal/payment/paypalpayment.php');

$paypal = new Paypal();

if (!$paypal->active)
exit;

$ppPayment = new PaypalPayment();
$errors = array();

// #####
// Functions

function getAuthorization()
{
global $ppPayment, $cookie, $cart;

$result = $ppPayment->getAuthorisation();
$logs = $ppPayment->getLogs();
if (is_array($result) AND sizeof($result))
{
if (strtoupper($result['ACK']) == 'SUCCESS')
{
if (isset($result['TOKEN']))
{
$cookie->paypal_token = strval($result['TOKEN']);
$cookie->paypal_token_date = time();
header('Location: https://'.$ppPayment->getPayPalURL().'/webscr&cmd=_express-checkout&token='.urldecode(strval($cookie->paypal_token)).'&useraction=commit');
exit;
}
else
$logs[] = '<b>'.$ppPayment->l('No token given by PayPal', 'submit').'</b>';
} else
$logs[] = '<b>'.$ppPayment->l('PayPal returned error', 'submit').'</b>';
}
$ppPayment->displayPayPalAPIError($ppPayment->l('Authorisation to PayPal failed', 'submit'), $logs);
}

function displayConfirm()
{
global $cookie, $smarty, $ppPayment, $cart;

if (!$cookie->isLogged(true))
{
header('location:../../../'); exit;
die('Not logged');
}
unset($cookie->paypal_token);

if ($cart->id_currency != $ppPayment->getCurrency((int)$cart->id_currency)->id)
{
$cart->id_currency = (int)($ppPayment->getCurrency((int)$cart->id_currency)->id);
$cookie->id_currency = (int)($cart->id_currency);
$cart->update();
Tools::redirect('modules/'.$ppPayment->name.'/payment/submit.php');
}

// Display all and exit
include(_PS_ROOT_DIR_.'/header.php');

$smarty->assign(array(
'logo' => $ppPayment->getLogo(),
'cust_currency' => $cart->id_currency,
'currency' => $ppPayment->getCurrency((int)$cart->id_currency),
'total' => $cart->getOrderTotal(true, Cart::BOTH),
'this_path_ssl' => Tools::getShopDomainSsl(true, true).__PS_BASE_URI__.'modules/'. $ppPayment->name.'/',
'mode' => 'payment/'
));

echo $ppPayment->display('paypal.php', 'confirm.tpl');
include(_PS_ROOT_DIR_.'/footer.php');
die ;
}

function submitConfirm()
{
global $cookie, $smarty, $ppPayment, $cart;

if (!$cookie->isLogged(true))
{
header('location:../../../'); exit;
die('Not logged');
}
elseif (!$id_currency = (int)(Tools::getValue('currency_payement')))
die('No currency');
elseif (!$cart->getOrderTotal(true, Cart::BOTH))
die('Empty cart');
$currency = new Currency((int)($id_currency));
if (!Validate::isLoadedObject($currency))
die('Invalid currency');
$cookie->id_currency = (int)($id_currency);
getAuthorization();
}

function validOrder()
{
global $cookie, $cart, $ppPayment;
if (!$cookie->isLogged(true))
{
header('location:../../../'); exit;
die('Not logged');
}
elseif (!$cart->getOrderTotal(true, Cart::BOTH))
die('Empty cart');
if (!$token = Tools::htmlentitiesUTF8(strval(Tools::getValue('token'))))
{
global $smarty;
$smarty->assign('paypalError', 'Invalid token');
displayConfirm();
die('Invalid token');
}
if ($token != strval($cookie->paypal_token))
die('Invalid cookie token');
if (!$payerID = Tools::htmlentitiesUTF8(strval(Tools::getValue('PayerID'))))
die('Invalid payerID');
$ppPayment->makePayPalAPIValidation($cookie, $cart, $cart->id_currency, $payerID, 'payment');
}

// #####
// Process !!

if (!$cookie->isLogged(true))
die('Not logged');
elseif (!$cart->getOrderTotal(true, Cart::BOTH))
die('Empty cart');

// No submit, confirmation page
if (!Tools::isSubmit('submitPayment') AND !Tools::getValue('fromPayPal'))
displayConfirm();
else
{
if (!isset($cookie->paypal_token) OR !$cookie->paypal_token)
submitConfirm();
validOrder();
}
Dziekuje za pomoc.

*

Offline mario

  • Mieszkaniec
  • *****
  • 640
  • 0
  • Płeć: Mężczyzna
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #22 dnia: Wrzesień 07, 2011, 09:11:07 pm »
Nie napisales jaka wersje presty masz
notabene Paypal zmienil cos w skryptach

aby to sprawdzic zrob backup swojego modulu paypal
sciagnij nowa instalacje presty z svn
skopiuj nowy modul paypal do swojego sklepu
i testuj

oczywiscie najpierw go odinstaluj
i zainstaluj nowy

mozliwe tez ze dane kontrahenta sa niepelne
jesli z GB to ok
« Ostatnia zmiana: Wrzesień 07, 2011, 09:29:42 pm wysłana przez mario »
Integracja wf-mag presta
freelancer

*

Offline zzxxcc

  • Nowy
  • *
  • 4
  • 0
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #23 dnia: Wrzesień 07, 2011, 09:28:20 pm »
Presta postawiona dzisiaj, v.1.4.4.1 (stable)
Modul PayPal v2.6.

Skopiowalem nowy modul, jednak sytuacja sie powtarza.
Kraj byl podany (United Kingdom).

Jakies pomysly?

*

Offline mario

  • Mieszkaniec
  • *****
  • 640
  • 0
  • Płeć: Mężczyzna
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #24 dnia: Wrzesień 07, 2011, 10:32:35 pm »
sprawdz w tabeli configuration wartosc dla
PAYPAL_MODE_DEBUG
w module nie masz ustawione?
Integracja wf-mag presta
freelancer

*

Offline zzxxcc

  • Nowy
  • *
  • 4
  • 0
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #25 dnia: Wrzesień 07, 2011, 10:53:27 pm »
Czy chodzi o ta wartosc?

Debug only: Activate long log message

W ustawieniach modulu probowalem wszystkich konfiguracji, zainstalowalem nowszy modul 2.8 lecz nadal nic nie pomoglo.

*

Offline mario

  • Mieszkaniec
  • *****
  • 640
  • 0
  • Płeć: Mężczyzna
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #26 dnia: Wrzesień 07, 2011, 11:26:39 pm »
Widac ze naglowki sa zdeformowane, musza przechodzic przez cache serwer ,lub parser nie wydala
Na innym hostingu probowales?
Integracja wf-mag presta
freelancer

*

Offline zzxxcc

  • Nowy
  • *
  • 4
  • 0
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #27 dnia: Wrzesień 07, 2011, 11:31:48 pm »
Niestety nie, sadzisz, ze problem lezy po stronie home.pl?

Wszystko wydaje sie OK, skrypt niby dziala, po wklejeniu ostatniej linijki przechodzi sie do strony z platnoscia, jednak jak go zmodyfikowac aby zmusic skrypt to wyegzekwowania otwarcia strony PayPala.

*

Offline OOczy

  • Nowy
  • *
  • 1
  • 0
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #28 dnia: Listopad 15, 2011, 12:46:40 am »
Niestety nie, sadzisz, ze problem lezy po stronie home.pl?

Wszystko wydaje sie OK, skrypt niby dziala, po wklejeniu ostatniej linijki przechodzi sie do strony z platnoscia, jednak jak go zmodyfikowac aby zmusic skrypt to wyegzekwowania otwarcia strony PayPala.
mysle ze wina jest po stronie home.pl.
mam wlasnie ten sam problem. dodalem sobie lokalnie domene w pdnsie taka jak wersja robocza sklepu i skonfigurowalem lokalnie moduł paypala dokladnie tak samo jak na produkcyjnym.
efekt: platnosc przechodzi bez zająknięcia... z tym homem na pewno jest coś na rzeczy.
zastanawiam sie tylko czy jest sens pisac w ogole do supportu...?
moze ktos juz rozgryzl ten problem?

*

Offline koniu12

  • Nowy
  • *
  • 17
  • 0
Odp: dla osob instalujacych PS na home.pl
« Odpowiedź #29 dnia: Grudzień 01, 2011, 11:43:16 am »
Mam ten sam problem z PayPalem i otrzymalem info od home.pl :

Prosze o modyfikacje pliku "/sklep/modules/paypal/api/paypalconnect.php" zmieniajac:

@curl_setopt($ch, CURLOPT_VERBOSE, true);
na:
@curl_setopt($ch, CURLOPT_VERBOSE, false);

Problem faktycznie znika, niestety w Explorer ukazuje sie blad, ze strona nie moze byc wyswietlona we "FRAME", po wybraniu "otworz w nowym oknie" pojawia sie wreszczie strona paypalu i wszystko juz gra jak powinno. Firefox wyswietla natomiast tylko biala strone i na tym koniec.

Czy ktos ma jeszcze jakies sugestie w sprawie tego problemu ?

Pzdr.