wdrożenia PrestaShop Powiększenie zdjęć moduł

OPTIK4LIFE

  • 12 Odpowiedzi
  • 3498 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline `zielu

  • Nowy
  • *
  • 6
  • 0
OPTIK4LIFE
« dnia: Styczeń 19, 2009, 10:33:37 pm »
Otwieram dla znajomego sklep internetowy pod adresem www.optik4life.pl

I potrzebuje paru wskazówek:
1. Gdzie mozna edytowac stopkę?
2. Jak umieścic nad kategoriami, ale pod banerem panel dla klienta (logowanie, rejestracja itp)
3. Usunąc te biale paski z boxow a zamiast fontowych linkow wsadzic tam grafikę?

I gdyby znalazl sie ktos tak dobry i podeslal mi pare linkow opisujacych jak mozliwie najlepiej dostosowac preste do polskich realiow...

ps. na www wrzucony jest sklep w wersji 1.0 ale bedziemy go budowac na 1.1, takze wszelkie uwagi i sugestie proszę odnosic do v1.1

Pozdrawiam i z gory dziekuje ^^

*

Offline qrczak

  • Tubylec
  • ****
  • 186
  • 1
  • Jello Biafra
  • Status: Właściciel
Odp: OPTIK4LIFE
« Odpowiedź #1 dnia: Styczeń 20, 2009, 12:45:07 am »
1. Gdzie mozna edytowac stopkę?

\themes\prestashop\footer.tpl

Reszte ci jutro opisze bu już nie kontaktuje :-)

*

Offline kuras

  • Tubylec
  • ****
  • 257
  • 1
Odp: OPTIK4LIFE
« Odpowiedź #2 dnia: Styczeń 20, 2009, 02:49:22 am »
3. Usunąc te biale paski z boxow a zamiast fontowych linkow wsadzic tam grafikę?

Gdzieś tam w pliku ze stylami global.css
jest linijka 878 gdzie znajdziesz
div.block h4 {
text-transform: uppercase;
font-family: Helvetica, Sans-Serif;
font-weight: bold;
font-size: 1.2em;
padding-left:0.5em;
border-bottom:1px solid #595A5E;
padding-top:2px;
line-height:1.3em;
color: #374853;
height: 19px;
background: transparent url('../img/block_header.gif') no-repeat top left;
}
I zamiast border-bottom:1px solid #595A5E;
dajesz np
border-bottom:0px solid #595A5E;
albo
border:0;

Powinno działać.

A jak zmienić tekst na obrazki...
Masz kod html
<h1 id="kat"><span>Kategorie</span></h1>
a w css dajesz
h1#kat {background: url(/img/kategorie.gif) left top no-repeat; width:200px; height:30px;}
i dalej
h1 span { display:none; }

Też powinno działać ;-)

*

Offline qrczak

  • Tubylec
  • ****
  • 186
  • 1
  • Jello Biafra
  • Status: Właściciel
Odp: OPTIK4LIFE
« Odpowiedź #3 dnia: Styczeń 20, 2009, 09:10:16 pm »
2. Jak umieścic nad kategoriami, ale pod banerem panel dla klienta (logowanie, rejestracja itp)
No z tym jest już nieco gorzej. W normaly sposób tego nie zrobisz, bo jak przeniesiesz blok "user info block" z sekcji top do innej to nigdzie ci tego bloku nie wyświetli. Ale spokojna bania i na to jest sposób.
Przyczyną tego (dla mnie niezrozumiałą) jest to, że autorzy postanowili "przyszyć" ten moduł na stałe do sekcji "top". Aby to zmienić najpierw w Back Office >> Modules >> Positions kasujesz moduł "User info block" z sekcji "top" i zaraz podpinasz go pod sekcję "Left column" i przesuwasz go na samą górę tej sekcji. Oczywiście na razie na naszej stronie nic się nie dzieje. Teraz wchodzimy do:
\modules\blockuserinfo\blockuserinfo.php i zmieniamy linijkę 22 na:
if (!$this->registerHook('leftColumn'))
oraz linijkę 33 na:
function hookLeftColumn($params)
i powinno działać czyli pojawić się na stronie.

*

Offline `zielu

  • Nowy
  • *
  • 6
  • 0
Odp: OPTIK4LIFE
« Odpowiedź #4 dnia: Styczeń 25, 2009, 12:46:34 pm »
Dziekuje wam bardzo wszystko jest pięknie i ladnie, ale jak spojzycie na strone sklepu to ten User Info Block nie jest tak jak inne, jakby nie miał tej ramki, tylko "wbił" mi sie w kategorie... Da sie temu jakos zaradzic?

I co z tym dostosowaniem sklepu do polskich realiow? ^^

*

Offline qrczak

  • Tubylec
  • ****
  • 186
  • 1
  • Jello Biafra
  • Status: Właściciel
Odp: OPTIK4LIFE
« Odpowiedź #5 dnia: Styczeń 25, 2009, 02:11:55 pm »
Nie mam teraz dostępu do swojego kompa więc nie mogę tego posprawdzać firebugiem i będę strzelał na oślep ale stawiam na brak clear:both gdzieś w css. Może trzeba w templatce dostawic gdzieś pomiędzy tym modułem a następnym <div class="clear" />.

*

Offline `zielu

  • Nowy
  • *
  • 6
  • 0
Odp: OPTIK4LIFE
« Odpowiedź #6 dnia: Styczeń 27, 2009, 08:42:46 pm »
poradzilem sobie juz ze wszystkim prawie, bo zostało mi np logo....

http://optik4life.ayz.pl/optik/

Ma byc ono przezroczyste, a wyglada tak jakby caly obszar na logo mial jeszcze bialy dodatkowy background... nie wiem gdize to ustawic... POMOZCIE! :(

edit: a... i jeszcze wysrodkowac obrazek ^^ ale to pewnie gdzies kolo tego koloru bedize...
« Ostatnia zmiana: Styczeń 27, 2009, 09:10:25 pm wysłana przez `zielu »

*

Offline `zielu

  • Nowy
  • *
  • 6
  • 0
Odp: OPTIK4LIFE
« Odpowiedź #7 dnia: Styczeń 31, 2009, 03:10:49 pm »
pomoze ktos z tym problemem? teraz logo ma dolozone tlo koloru backgroundu, ale dalej nie potrafie uzyskac tej przezroczystosci... :/

*

Offline kuras

  • Tubylec
  • ****
  • 257
  • 1
Odp: OPTIK4LIFE
« Odpowiedź #8 dnia: Styczeń 31, 2009, 10:03:19 pm »
Ja bym coś mógł pomóc ale nie wiem co?!?  ;D

Widzę duży obrazek w nagłówku http://optik4life.ayz.pl/optik/img/logo.jpg
i co z nim ma być?
Gdzie jest ten "bialy dodatkowy background" bo ja go nie widzę...

Czy chodzi ci o to aby było widać powtarzające się karty i napis OPTI 4 LIFE pod obrazkiem nagłowka?

*

Offline `zielu

  • Nowy
  • *
  • 6
  • 0
Odp: OPTIK4LIFE
« Odpowiedź #9 dnia: Luty 03, 2009, 04:56:46 pm »
teraz logo ma dolozone tlo koloru backgroundu, ale dalej nie potrafie uzyskac tej przezroczystosci... :/

Tak jak napisalem, dodalem szare tlo do loga... ale tak jak pisał @kuras chodzi mi o uzyskanie przezroczystosci na tym obrazku, zeby bylo widac te karty i napisy z ogolnego backgroundu strony...



doszedł kolejny problem, a w sumie dwa... zrobione są obrazki do boxow i tła...
Tyle że cos jest nie tak...
> tło w boxach: ostatnio przeglądane i nowe produkty zaczyna się jakoś dziwnie od polowy... grafika jest jednolita, różowa, bez żadnego gradientu...
> tworzy się 1px odstęp pomiędzy tłem boxa a headerem...

:(  ???

*

Offline slash5

  • Użytkownik
  • **
  • 35
  • 0
Odp: OPTIK4LIFE
« Odpowiedź #10 dnia: Luty 03, 2009, 07:16:59 pm »
jak chcesz grafike przezroczysta musisz zrobic obraz na transparencie i zapisac go jako .png lub .gif... IE 6 dodaje tlo do png... co do wygladu boxow opisz dokladniej

*

Offline `zielu

  • Nowy
  • *
  • 6
  • 0
Odp: OPTIK4LIFE
« Odpowiedź #11 dnia: Luty 07, 2009, 04:43:59 pm »


1 tło w boxach: ostatnio przeglądane i nowe produkty zaczyna się jakoś dziwnie od polowy... obrazek tła jest jednolity, różowy, bez żadnego gradientu...
2 tworzy się 1px odstęp pomiędzy tłem boxa a headerem...



jak chcesz grafike przezroczysta musisz zrobic obraz na transparencie i zapisac go jako .png lub .gif... IE 6 dodaje tlo do png... co do wygladu boxow opisz dokladniej

to akurat wiem... ale gdy zapisze png/gif bez tła, jako transparent, to nie moge go uzyskac bo pod obrazek wrzuca się automatycznie białe tło gdzieś z kodu strony...

*

Offline christo123

  • Stały użytkownik
  • ***
  • 65
  • 1
Odp: OPTIK4LIFE
« Odpowiedź #12 dnia: Luty 07, 2009, 07:43:45 pm »
Myślę, że ten jeden piksel to źle ustawiona wysokość H4. Na realną wysokość składają się następujące parametry: height i padding (top i bottom). Inna możliwość, że tło ma brak repeat-y przy background.
Tak więc proszę sprawdzić odwołania do div.block.h4 i div.block.

Na przyszłość polecam Firefox'a z odpowiednim pluginem (firebug). Można tam w locie ustalać parametry i patrzeć jak się zmienia aby to później w pliku css poprawić.

Pozdrawiam
Krzysiek