wdrożenia PrestaShop

Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)

  • 158 Odpowiedzi
  • 79990 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline TePe

  • Stały użytkownik
  • ***
  • 63
  • 0
  • Płeć: Mężczyzna
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #30 dnia: Luty 12, 2009, 06:57:52 pm »
Mam problem z instalacją (rev50) serwer przechodzi wszystkie testy na "zielono"
Podaje namiary na baze danych testuje połączenie jest ok, klikam dalej ....... i nic się nie dzieje
nie wyskakuje żaden błąd, poprostu nie da się przejsc do nastepnego kroku.

Spotkał się kiedyś ktoś z takim problemem ?
Moduł Porównywarek cenowych (ceneo radar skapiec nokaut) dla PrestaShop 1.2.5,  1.3.0, 1.4
W pełni działający moduł Płatności.pl dla PrestaShop 1.2.5, 1.3.0 i 1.4 wzwyż
dostępne na: www.prestamarket.pl

*

Offline christo123

  • Stały użytkownik
  • ***
  • 65
  • 1
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #31 dnia: Luty 12, 2009, 07:13:48 pm »
Gdy w plikach .sql jest błąd to czasami pokazuje błąd a czasami go nie pokazuje. Prawdopodobnie gdzieś w pliku .sql jest błąd tego typu (przykład):
INSERT INTO `PREFIX_attribute_group_lang` VALUES
(1, 1, 'Disk space', 'Disk space'),
(1, 2, 'Capacité', 'Capacité'),
(1, 1, 'Pojemność', 'Pojemność'),
...

*

Offline TePe

  • Stały użytkownik
  • ***
  • 63
  • 0
  • Płeć: Mężczyzna
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #32 dnia: Luty 12, 2009, 07:17:34 pm »
wlasnie wgrywam orginalna wersje bez modyfikacji zobaczymy czy pomoze
Moduł Porównywarek cenowych (ceneo radar skapiec nokaut) dla PrestaShop 1.2.5,  1.3.0, 1.4
W pełni działający moduł Płatności.pl dla PrestaShop 1.2.5, 1.3.0 i 1.4 wzwyż
dostępne na: www.prestamarket.pl

*

Offline TePe

  • Stały użytkownik
  • ***
  • 63
  • 0
  • Płeć: Mężczyzna
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #33 dnia: Luty 12, 2009, 08:20:44 pm »
niestety na oryginalnej instalacji też nie przechodzi, może jakieś złe ustawienia serwera ?
Moduł Porównywarek cenowych (ceneo radar skapiec nokaut) dla PrestaShop 1.2.5,  1.3.0, 1.4
W pełni działający moduł Płatności.pl dla PrestaShop 1.2.5, 1.3.0 i 1.4 wzwyż
dostępne na: www.prestamarket.pl

*

Offline christo123

  • Stały użytkownik
  • ***
  • 65
  • 1
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #34 dnia: Luty 12, 2009, 08:42:06 pm »
A wszystkie trzy pliki .sql w instalce podmieniłeś?

*

Offline TePe

  • Stały użytkownik
  • ***
  • 63
  • 0
  • Płeć: Mężczyzna
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #35 dnia: Luty 12, 2009, 09:14:48 pm »
nic nie podmnienialem wgrałem cała świeżą instalkę z prestashop.com
Moduł Porównywarek cenowych (ceneo radar skapiec nokaut) dla PrestaShop 1.2.5,  1.3.0, 1.4
W pełni działający moduł Płatności.pl dla PrestaShop 1.2.5, 1.3.0 i 1.4 wzwyż
dostępne na: www.prestamarket.pl

*

Offline qrczak

  • Tubylec
  • ****
  • 186
  • 1
  • Jello Biafra
  • Status: Właściciel
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #36 dnia: Luty 13, 2009, 09:51:06 am »
nic nie podmnienialem wgrałem cała świeżą instalkę z prestashop.com
Dalej masz taki problem? Generalnie staram się przed każdą rewizją samemu zainstalować nową wersję, żeby sprawdzić czy przechodzi instalację.
Co do przykładowego błędu podanego przez @christo123 gdzie id_lang był po raz drugi taki sam przy tym samym id_attribute to jeszcze mogło się zdarzyć, że gdzieś seria wpisów do bazy dla jednej tabeli nie kończy się ";" a np. tylko ",".

A co się tyczy instalki bezposrednio z prestashop.com to instaluje się u mnie bez bólu tak na localhoscie jak na serwerze online.

*

Offline TePe

  • Stały użytkownik
  • ***
  • 63
  • 0
  • Płeć: Mężczyzna
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #37 dnia: Luty 13, 2009, 03:35:05 pm »
Dalej masz taki problem? Generalnie staram się przed każdą rewizją samemu zainstalować nową wersję, żeby sprawdzić czy przechodzi instalację.
Co do przykładowego błędu podanego przez @christo123 gdzie id_lang był po raz drugi taki sam przy tym samym id_attribute to jeszcze mogło się zdarzyć, że gdzieś seria wpisów do bazy dla jednej tabeli nie kończy się ";" a np. tylko ",".

A co się tyczy instalki bezposrednio z prestashop.com to instaluje się u mnie bez bólu tak na localhoscie jak na serwerze online.


no własnie u mnie zawsze też przechodziło bez problemu, teraz robię sklep na innym serwerze i tu problem, może serwer musi mieć jakieś specjalne ustawienia ?
Moduł Porównywarek cenowych (ceneo radar skapiec nokaut) dla PrestaShop 1.2.5,  1.3.0, 1.4
W pełni działający moduł Płatności.pl dla PrestaShop 1.2.5, 1.3.0 i 1.4 wzwyż
dostępne na: www.prestamarket.pl

*

Offline chinskimandaryn

  • Mieszkaniec
  • *****
  • 339
  • 0
  • Płeć: Mężczyzna
    • www.chinskimandaryn.pl
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #38 dnia: Luty 13, 2009, 07:59:00 pm »
Wymagań jakiś strasznych nie ma:
http://www.prestashop.com/wiki/Getting_Started/#System_Requirements

, chodzi w zasadzie wszędzie, co najwyżej możnaby jeszcze popróbować i pozmieniać coś w .htaccess
http://www.prestashop.com/wiki/activate_PHP5/

Na jednym hostingu np. dla prawidłowego działania potrzebne było dodanie w .htaccess :
RewriteBase /

*

Offline Clocky Fan

  • Nowy
  • *
  • 8
  • 0
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #39 dnia: Luty 13, 2009, 08:00:41 pm »
Jeśli masz dostęp do logów Apache'a i PHP, to warto tam zajrzeć. Być może będzie tam wskazówka, co idzie nie tak.
Clocky Fan
http://clocky.pl - uciekające budziki

*

Offline chinskimandaryn

  • Mieszkaniec
  • *****
  • 339
  • 0
  • Płeć: Mężczyzna
    • www.chinskimandaryn.pl
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #40 dnia: Luty 13, 2009, 08:02:35 pm »
Można też włączyć, by PHP wyświetlało komunikaty błędów bezpośrednio na www

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 3,678
  • 91
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #41 dnia: Luty 15, 2009, 02:36:44 pm »
Jeśli uprawnienia były na Twoim serwerze wystarczające oznacza to, że administratorzy stosują łagodną politykę bezpieczeństwa. Na stronie projektu można przeczytać następującą uwagę:
[...] Należy ustawić 777 dla następujących katalogów: /config, /upload, /download, /tools/smarty/compile. oraz upewnić się, że następujące podfoldery mają również prawa do zapisu: /img, /mails, /modules, /themes/prestashop/lang, /translations[/[...]
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline chinskimandaryn

  • Mieszkaniec
  • *****
  • 339
  • 0
  • Płeć: Mężczyzna
    • www.chinskimandaryn.pl
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #42 dnia: Luty 16, 2009, 10:07:28 am »
[...] Należy ustawić 777 dla następujących katalogów: /config, /upload, /download, /tools/smarty/compile. oraz upewnić się, że następujące podfoldery mają również prawa do zapisu: /img, /mails, /modules, /themes/prestashop/lang, /translations[/[...]

Czy to, że zmieniamy rekurencyjnie prawa dla podfolderów, jest też równoznaczne z tym, że powinniśmy zmienić także prawa dla istniejących w nich plików na 777



np. jeśli używam programu FileZilla, to której opcji użyć?



Której opcji użyć 1 czy 2?

*

Offline TePe

  • Stały użytkownik
  • ***
  • 63
  • 0
  • Płeć: Mężczyzna
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #43 dnia: Luty 16, 2009, 06:14:12 pm »
Próbowałem dzisiaj zainstalować na nowo polską wersję PS na serwerze nazwa.pl .
Poprzdnio instalację przechodziły bez problemu, a teraz nie chcą, nie wiem w czym jest problem :/
Kasuję wszystkie pliki z serwera wgrywam na nowo, zakładam nową bazę z bazą jest połączenie, ale do punktu 4 instalacji przejść się już nie da :/
Moduł Porównywarek cenowych (ceneo radar skapiec nokaut) dla PrestaShop 1.2.5,  1.3.0, 1.4
W pełni działający moduł Płatności.pl dla PrestaShop 1.2.5, 1.3.0 i 1.4 wzwyż
dostępne na: www.prestamarket.pl

*

Offline pawelpon

  • Stały użytkownik
  • ***
  • 84
  • 3
    • Specjalistyczne zawiesia, uchwyty i trawesy.
Odp: Problem z instalacją? (Instalujesz pierwszy raz - zobacz!)
« Odpowiedź #44 dnia: Luty 16, 2009, 06:36:02 pm »
Którą wersje próbowałeś instalować ?