wdrożenia PrestaShop Powiększenie zdjęć moduł wdrożenia PrestaShop

HTTP Error 500 w panelu admina

  • 12 Odpowiedzi
  • 853 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline rrafix

  • Użytkownik
  • **
  • 21
  • 0
  • PrestaShop
  • Presta Shop: PS
  • Status: forum
HTTP Error 500 w panelu admina
« dnia: Styczeń 22, 2019, 01:36:51 pm »
Po przeniesieniu strony na inny serwer nie mam dostępu do panelu admina.
Pojawia się błąd HTTP Error 500.
W trybie debugowania taki błąd jak w załączniku

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 4,970
  • 100
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #1 dnia: Styczeń 22, 2019, 06:16:43 pm »
Sprawdź czy wszystkie pliki przeniosłeś. Po dwa przed przeniesieniem wyłączyłeś cache ?
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline rrafix

  • Użytkownik
  • **
  • 21
  • 0
  • PrestaShop
  • Presta Shop: PS
  • Status: forum
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #2 dnia: Styczeń 22, 2019, 06:53:26 pm »
Nie wyłączyłem cache.
Czy mogę o bardziej szczegółowy opis o co z tym chodzi?

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 4,970
  • 100
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #3 dnia: Styczeń 23, 2019, 11:14:23 am »
musisz wyłączyć cache oraz wstawić "czysty" folder cache do nowego sklepu
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline rrafix

  • Użytkownik
  • **
  • 21
  • 0
  • PrestaShop
  • Presta Shop: PS
  • Status: forum
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #4 dnia: Styczeń 23, 2019, 02:19:50 pm »
Jak w presta 1.7 wyłączyć cache z poziomu bazy lub ftp ?
Czy mogę to zrobić po już przeniesieniu czy mam wyłączyć cache będą na starym serwerze i od nowa robić transfer plików strony?

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 4,970
  • 100
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #5 dnia: Styczeń 23, 2019, 06:32:01 pm »
jeśli nie możesz znaleźć ustawień w plikach wyłącz na starym sklepie skopiuj tylko bazę danych oraz tak jak pisałem cały nowy katalog cache
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline rrafix

  • Użytkownik
  • **
  • 21
  • 0
  • PrestaShop
  • Presta Shop: PS
  • Status: forum
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #6 dnia: Styczeń 27, 2019, 07:00:34 pm »
Niestety żadna z podpowiedzi nie rozwiązała problemu.
Nie jest to problem bazy danych ponieważ strona na starym serwerze podpięta do bazy na nowym serwerze działa poprawnie.

Proszę o dalsze wskazówki

*

Offline rrafix

  • Użytkownik
  • **
  • 21
  • 0
  • PrestaShop
  • Presta Shop: PS
  • Status: forum
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #7 dnia: Luty 08, 2019, 08:46:35 am »
temat cały czas aktualny więc podbijam

*

Offline endriu107

  • user
  • Mieszkaniec
  • *****
  • 1,197
  • 51
  • Presta Shop: PS
  • Status: forum
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #8 dnia: Luty 10, 2019, 11:40:57 am »
Jaka wersja php jest na starym i na nowym serwerze?

*

Offline rrafix

  • Użytkownik
  • **
  • 21
  • 0
  • PrestaShop
  • Presta Shop: PS
  • Status: forum
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #9 dnia: Luty 10, 2019, 03:18:30 pm »
Twoje pytanie podpowiedziało nasunęło mi pomysł aby zmienić wersję i to był strzał w 10.
Strona się wyświetla z jednym małym problemem.

Na samej górze wyświetla się następujący błąd:
Warning: file_get_contents(/themes/noka-se/assets/js/custom.js): failed to open stream: No such file or directory in /home/users/nokasc/public_html/moblernoka.se/classes/assets/JavascriptManager.php on line 115

W trybie debugowania:
(1/1) ContextErrorException
Warning: file_get_contents(/themes/noka-se/assets/js/custom.js): failed to open stream: No such file or directory

in JavascriptManager.php line 115
at JavascriptManagerCore->addInlinedJavascriptContent()
in JavascriptManager.php line 104
at JavascriptManagerCore->getList()
in FrontController.php line 600
at FrontControllerCore->getJavascript()
in FrontController.php line 661
at FrontControllerCore->display()
in Controller.php line 301
at ControllerCore->run()
in Dispatcher.php line 509
at DispatcherCore->dispatch()
in index.php line 28


Nie bardzo wiem jak sobie z tym poradzić

*

Offline endriu107

  • user
  • Mieszkaniec
  • *****
  • 1,197
  • 51
  • Presta Shop: PS
  • Status: forum
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #10 dnia: Luty 10, 2019, 09:32:43 pm »
Sprawdź czy wspomniany plik jest fizycznie na serwerze, czasami po przeniesieniu sklepu okazuje się ze kilka plików brakuje lub mają zmienione nazwy np. pliki są z małych liter zamiast z dużych.

*

Offline rrafix

  • Użytkownik
  • **
  • 21
  • 0
  • PrestaShop
  • Presta Shop: PS
  • Status: forum
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #11 dnia: Luty 10, 2019, 09:35:14 pm »
sprawdzałem 100 razy. Plik jest!

Błąd najprawdopodobniej związany jest z błędną ścieżką do plików, gdyż na
serwerze nie ma pliku /themes/noka-se/assets/js/custom.js ale jest
themes/noka-se/assets/js/custom.js. Proszę zauważyć, że na początku
lokalizacji pliku jest znak "/" co oznacza katalog główny serwera, dlatego
też serwer nie może znaleźć pliku.

Ścieżka do pliku wygląda tak:

 /themes/noka-se/assets/js/custom.js

a powinna wyglądać tak:

/home/users/nokasc/public_html/moblernoka.se/themes/noka-se/assets/js/custom.js

Niestety nie wiem jak i gdzie to poprawić??

*

Offline rrafix

  • Użytkownik
  • **
  • 21
  • 0
  • PrestaShop
  • Presta Shop: PS
  • Status: forum
Odp: HTTP Error 500 w panelu admina
« Odpowiedź #12 dnia: Luty 10, 2019, 10:39:05 pm »
tymczasowo zawieszam... ponownie przesłałem pliki i błędu nie widać.
Oby tak pozostało...