wdrożenia PrestaShop Powiększenie zdjęć moduł wdrożenia PrestaShop

Znikające elementy w wersji mobilnej

  • 4 Odpowiedzi
  • 290 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline giees

  • Użytkownik
  • **
  • 21
  • 0
  • PrestaShop
  • Presta Shop: 1.6
  • Status: Właściciel
Znikające elementy w wersji mobilnej
« dnia: Grudzień 21, 2018, 10:00:16 am »
Presta 1.6 + integracja fotolia, https://digitaldruk.pl

Na kartach produktu w mobilnej wersji sklepu znika mi zawartość dodatkowych modułów (ale nie całe moduły, bo nagłówki zostają).

W przypadku produktów niezwiązanych z fotolią znika mi zawartość 2 na 3 moduły (related product oraz inne produkty w kategorii), natomiast na karcie produktu z integracji fortolia pod zdjęciem znika wszystko - wizualizacje, opis, zdjęcia z tej samej kategorii.


*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 4,709
  • 99
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: Znikające elementy w wersji mobilnej
« Odpowiedź #1 dnia: Grudzień 21, 2018, 12:03:54 pm »
Zobacz:
1. czy dany moduł ma zaznaczoną opcję pokaż / ukryj na telefonach / tabletach.
2. Czy w product.tpl dane elementy nie są poukrywane w trybie mobilnym poprzez instrukcję hidden-xs lub w plikach css
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline giees

  • Użytkownik
  • **
  • 21
  • 0
  • PrestaShop
  • Presta Shop: 1.6
  • Status: Właściciel
Odp: Znikające elementy w wersji mobilnej
« Odpowiedź #2 dnia: Grudzień 21, 2018, 12:36:20 pm »
1) Wszystko jest OK,
2) Zarówno product.tpl oraz global.css się nie zmieniło, bo porównałem z backupem.

Zawartość pliku css modułu 'produkty tej samej kategorii' (productscategory.css), który m.in. przestaje wyświetlać zdjęcia w wersji mobilnej:
h2.productscategory_h2 {
margin:40px 0 20px 0;
padding:10px 0;
border-bottom:1px solid #ccc;
font-size:18px;
color:#333
}

#productscategory {overflow:auto}

#productscategory_list {
overflow: hidden;
float: left;
width: 96%;
}
#productscategory_list ul {
list-style-type:none;
margin: 0 0 0 14px;
}
#productscategory_list li {
float:left;
margin: 0 9px;
    padding: 0 5px;
}

@media screen and (-webkit-min-device-pixel-ratio:0) {
#productscategory_list li   {
margin: 0 7px;
}
}

#productscategory_list li a.lnk_img {display:block}
#productscategory_list li a img {border:1px solid #ccc}
#productscategory_list li p.product_name {text-align:center}

#productscategory_noscroll {
height: 120px;
width: 100%;
margin-bottom: 30px;
}

#productscategory_scroll_left, #productscategory_scroll_right {
background: url('../img/thumbs_left.gif') no-repeat center;
text-indent: -3000px;
display: block;
width: 9px;
height: 18px;
float: left;
margin-top: 30px;
}

#productscategory_scroll_right { background-image: url('../img/thumbs_right.gif'); }

*

Offline endriu107

  • user
  • Mieszkaniec
  • *****
  • 1,190
  • 52
  • Presta Shop: PS
  • Status: forum
Odp: Znikające elementy w wersji mobilnej
« Odpowiedź #3 dnia: Grudzień 21, 2018, 10:48:19 pm »
Przeszukaj pliki pod kątem zawartości tego kodu:

.block_content {
    display: none;
}

weź pod uwagę wyniki które znajdują sie w znacznikach @media tak znajdziesz gdzie to jest definiowane.

*

Offline giees

  • Użytkownik
  • **
  • 21
  • 0
  • PrestaShop
  • Presta Shop: 1.6
  • Status: Właściciel
Odp: Znikające elementy w wersji mobilnej
« Odpowiedź #4 dnia: Grudzień 22, 2018, 10:55:48 am »
Oświeciło mnie i przypomniałem sobie, że jakiś czas temu grzebałem w plikach css modułu z opiniami klientów. Chciałem, aby widżet znikał w wersji mobilnej, więc dodałem do store_widget.css:
@media (max-width: 850px)
{
.block_content{
display: none;
}
}

@media (max-width: 850px)
{
.close_widget_block{
display: none;
}
}

Problem w tym, że teraz po usunięciu tego kodu i wyczyszczeniu całego cache w sklepie, problem na kartach produktu nadal nie zniknął, choć widżet w wersji mobilnej znów się pojawia.

E:
Problem tkwi w module opinii klientów, ponieważ po wyłączeniu modułu na karcie produktu wszystko jest OK. Co dziwne przy włączonym module widżet znika tylko tylko na produktach (razem z dodatkowymi elementami), natomiast na stronie głównej w wersji mobilnej wyświetla się cały czas.
« Ostatnia zmiana: Grudzień 22, 2018, 11:29:50 am wysłana przez giees »