wdrożenia PrestaShop Powiększenie zdjęć moduł wdrożenia PrestaShop

Problem z wysyłaniem poczty i powiadomień

  • 3 Odpowiedzi
  • 696 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline apopo

  • Użytkownik
  • **
  • 23
  • 0
  • prestashop
  • Presta Shop: PS
  • Status: forum
Problem z wysyłaniem poczty i powiadomień
« dnia: Maj 08, 2018, 04:08:08 pm »
Witam,

od kilku dni mam problem z wysyłaniem wiadomości ze sklepu, klienci nie otrzymują powiadomień.

Podczas próby wysłanai wiadomości testowej sklep twierdzi, że jest błąd konfiguracji, a podczas próby wysłania wiadomości do klienta pojawia się błąd: "Swift Mailer was not found. Please download Swift Mailer 5.4.x at https://github.com/swiftmailer/swiftmailer/releases and copy swift_required.php file with all other files to public_html/tools/swift5/ directory retaining the directory structure. Niestety wgranie tego katalogu na serwer nie pomaga (nic się nie zmienia). Dodam, że w katalogu tools jest podkatalog swift, a w nim plik swift_required.php.

Hosting twierdzi, że konfiguracja poczty w sklepie jest prawidłowa a problem leży po stronie sklepu, który z jakiegoś powodu blokuje wysyłkę poczty.

Presta 1.6.1.18

Problem wystepuje zarówno przy ustawieniu mail PHP, jak i przy SMTP.

Proszę o pomoc.

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 4,656
  • 99
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: Problem z wysyłaniem poczty i powiadomień
« Odpowiedź #1 dnia: Maj 08, 2018, 09:45:42 pm »
Jakiś magik zaktualizował Ci Swift :) Ściągnij oryginalne pliki instalacyjne z prestashop.com i podmień w swojej instalacji
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline apopo

  • Użytkownik
  • **
  • 23
  • 0
  • prestashop
  • Presta Shop: PS
  • Status: forum
Odp: Problem z wysyłaniem poczty i powiadomień
« Odpowiedź #2 dnia: Maj 09, 2018, 05:24:19 pm »
Które dokładnie pliki mam podmienić?
Sklep był stawiany na innej, wcześniejszej wersji Presty a następnie aktualizowany aż do wersji 1.6.1.18.
Czy w związku z tym te pliki z nowej instalki będą dokładnie do siebie pasowały?
Przy próbie wysyłania wiadomości do klienta (zmiana statusu) pojawł mi się następujący komunikat:
"Warning w linii 749 w pliku /home/apopo/domains/apopo.pl/public_html/classes/Mail.php
[512] Swift Mailer was not found. Please download Swift Mailer 5.4.x at https://github.com/swiftmailer/swiftmailer/releases and copy swift_required.php file with all other files to public_html/tools/swift5/ directory retaining the directory structure."
Zajrzałem do linii 749 i mam tam coś takiego: "trigger_error($msg, E_USER_WARNING);" a w linii 750: "return false;"
Nie wiem co mam z tym zrobić.

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 4,656
  • 99
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: Problem z wysyłaniem poczty i powiadomień
« Odpowiedź #3 dnia: Maj 09, 2018, 06:58:15 pm »
Nie rozumiem o co pytasz. Maasz dokładnie napisane [w nie naszym jęz] czego brakuje. Ja natomiast powiedziałem ci dokładnie co masz zrobić
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz