wdrożenia PrestaShop

po aktualizacji błąd 500

  • 15 Odpowiedzi
  • 1309 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline agata-access

  • Nowy
  • *
  • 2
  • 0
  • PrestaShop
  • Presta Shop: PS
  • Status: forum
po aktualizacji błąd 500
« dnia: Czerwiec 19, 2017, 07:58:17 pm »
Witam
Mam problem do tej pory miałam prestashop 1.6.1.6 za pomocą 1-click zrobiłam aktualizację do wersji 1.6.1.14, niestety po aktualizacji okazało się, że sklep nie działa tak więc korzystając z możliwości dostępnej w module 1-click powróciłam do starej opcji i tu zaczęły się problemy, nie tylko sklep nie działał ale straciłam dostęp do panelu. Tak więc jedyna opcja jaka pozostała to wprowadzenie backup. Skorzystałam z backupa z dnia poprzedniego, ale niestety wyskakuje błąd . Jedyny poprawny backup jaki wchodzi to ten z przed kilkunastu dni, a to sprawia, że straciłam dane zamówień i klientów. Co może oznaczać ten błąd i jak go naprawić

[Mon Jun 19 13:04:13.300103 2017] [proxy_fcgi:error] [pid 6311:tid 139744528717568] [client 162.158.102.17:19253] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: id_parent in
« Ostatnia zmiana: Czerwiec 19, 2017, 11:24:02 pm wysłana przez west »

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 3,733
  • 93
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: po aktualizacji błąd 500
« Odpowiedź #1 dnia: Czerwiec 19, 2017, 11:25:34 pm »
brak pliku jakiegoś :) bo niestety ucięło jakiego. Dlaczego kopia jest niepoprawna ? Aby odzyskać dane o zamówieniach wystarczy wgrać samą bazę danych z kopii lub lokalnie i ewentualnie je połączyć.
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline agata-access

  • Nowy
  • *
  • 2
  • 0
  • PrestaShop
  • Presta Shop: PS
  • Status: forum
Odp: po aktualizacji błąd 500
« Odpowiedź #2 dnia: Czerwiec 20, 2017, 10:24:47 am »
brak pliku jakiegoś :) bo niestety ucięło jakiego. Dlaczego kopia jest niepoprawna ? Aby odzyskać dane o zamówieniach wystarczy wgrać samą bazę danych z kopii lub lokalnie i ewentualnie je połączyć.

Niestety nie mogą już skopiować błędu, w każdym bądź razie wskazywała na błąd w pliku
 pliku classes/Tab i tu wyskakiwał Undefined index: id_parent

  if ($admin_tab['id_parent'] > 0) {

classes/controller/AdminController

if (isset($tabs[0])) {
            $this->addMetaTitle($tabs[0]['name']);
            $breadcrumbs2['tab']['name'] = $tabs[0]['name'];
            $breadcrumbs2['tab']['href'] = __PS_BASE_URI__.basename(_PS_ADMIN_DIR_).'/'.$this->context->link->getAdminLink($tabs[0]['class_name']);
            if (!isset($tabs[1])) {
                $breadcrumbs2['tab']['icon'] = 'icon-'.$tabs[0]['class_name'];
            }

Czy mogę do kopi zapasowej plików FTB z dnia 24.05 wgrać bazę danych z 17.06 tak by nie było zgrzytów
« Ostatnia zmiana: Czerwiec 20, 2017, 10:28:28 pm wysłana przez west »

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 3,733
  • 93
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: po aktualizacji błąd 500
« Odpowiedź #3 dnia: Czerwiec 20, 2017, 10:28:59 pm »
Czemu nie mogą :P
Porównaj wersje jakie miałaś musza być te same
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline lukruk

  • Nowy
  • *
  • 13
  • 0
  • Presta Shop: 1.6.1
  • Status: forum
Odp: po aktualizacji błąd 500
« Odpowiedź #4 dnia: Lipiec 15, 2017, 12:04:19 am »
Mam podobny problem. Również nie mogę wejść na panel sterowania. Przy włączaniu strony pokazuje mi się komunikat:
https://zapodaj.net/d7bdaacd13d33.jpg.html
Log z błędami:
[Wed Jul 05 13:50:09.775544 2017] [fcgid:warn] [pid 5961:tid 140158801366784] [client 91.246.70.194:58604] mod_fcgid: stderr: PHP Warning: Invalid argument supplied for foreach() in /home/eimpact/domains/e-impact.pl/public_html/sklep/classes/shop/Shop.php on line 337, referer: http://e-impact.pl/
[Wed Jul 05 13:50:10.130833 2017] [fcgid:warn] [pid 5961:tid 140158797520640] [client 91.246.70.194:58605] mod_fcgid: stderr: PHP Warning: Invalid argument supplied for foreach() in /home/eimpact/domains/e-impact.pl/public_html/sklep/classes/shop/Shop.php on line 337, referer: http://e-impact.pl/

Może zna ktoś rozwiązanie mojego problemu ?

*

Offline endriu107

  • user
  • Mieszkaniec
  • *****
  • 1,080
  • 50
  • Presta Shop: PS
  • Status: forum
Odp: po aktualizacji błąd 500
« Odpowiedź #5 dnia: Lipiec 15, 2017, 08:07:56 am »
Włącz tryb debugowania wtedy dopiero mogą się pojawić prawdziwe komunikaty o błędach.

*

Offline lukruk

  • Nowy
  • *
  • 13
  • 0
  • Presta Shop: 1.6.1
  • Status: forum
Odp: po aktualizacji błąd 500
« Odpowiedź #6 dnia: Lipiec 17, 2017, 05:03:03 pm »
Włącz tryb debugowania wtedy dopiero mogą się pojawić prawdziwe komunikaty o błędach.

W jaki sposób mogę włączyć ten tryb ?

*

Offline endriu107

  • user
  • Mieszkaniec
  • *****
  • 1,080
  • 50
  • Presta Shop: PS
  • Status: forum

*

Offline lukruk

  • Nowy
  • *
  • 13
  • 0
  • Presta Shop: 1.6.1
  • Status: forum
Odp: po aktualizacji błąd 500
« Odpowiedź #8 dnia: Lipiec 17, 2017, 11:51:13 pm »
niestety włączenie trybu debugowania nic nie dało :(
http://e-impact.pl/sklep/
Spotkał się z was kiedyś z takim problemem ?

*

Offline lukruk

  • Nowy
  • *
  • 13
  • 0
  • Presta Shop: 1.6.1
  • Status: forum
Odp: po aktualizacji błąd 500
« Odpowiedź #9 dnia: Lipiec 18, 2017, 09:47:10 pm »
Może pomocny będzie dla kogoś fakt że błąd pojawił się po tym jak wcześniejszy zarządca sklepu zmienił ustawienia DNS na serwerze hostingowym. Po jego zmianie sklep przestał działać. Musiałem również jeszcze raz ustawiać hasła do kont pocztowych.

*

Offline lukruk

  • Nowy
  • *
  • 13
  • 0
  • Presta Shop: 1.6.1
  • Status: forum
Odp: po aktualizacji błąd 500
« Odpowiedź #10 dnia: Lipiec 18, 2017, 10:33:31 pm »
Zmieniłem wersję php na niższą i wyświetliło mi się:
[PrestaShopDatabaseException]

Table 'eimpact_ps1.ps_shop_url' doesn't exist

SELECT s.id_shop, CONCAT(su.physical_uri, su.virtual_uri) AS uri, su.domain, su.main
FROM ps_shop_url su
LEFT JOIN ps_shop s ON (s.id_shop = su.id_shop)
WHERE (su.domain = 'e-impact.pl' OR su.domain_ssl = 'e-impact.pl')
AND s.active = 1
AND s.deleted = 0
ORDER BY LENGTH(CONCAT(su.physical_uri, su.virtual_uri)) DESC


at line 791 in file classes/db/Db.php

786.         if ($webservice_call && $errno) {
787.             $dbg = debug_backtrace();
788.             WebserviceRequest::getInstance()->setError(500, '[SQL Error] '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97);
789.         } elseif (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS')) {
790.             if ($sql) {
791.                 throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>');
792.             }
793.
794.             throw new PrestaShopDatabaseException($this->getMsgError());
795.         }
796.     }

    DbCore->displayError - [line 425 - classes/db/Db.php] - [1 Arguments]
    DbCore->query - [line 643 - classes/db/Db.php] - [1 Arguments]
    DbCore->executeS - [line 334 - classes/shop/Shop.php] - [1 Arguments]
    ShopCore::initialize - [line 114 - config/config.inc.php]
    require - [line 27 - index.php] - [1 Arguments]

*

Offline endriu107

  • user
  • Mieszkaniec
  • *****
  • 1,080
  • 50
  • Presta Shop: PS
  • Status: forum
Odp: po aktualizacji błąd 500
« Odpowiedź #11 dnia: Lipiec 19, 2017, 07:25:00 am »
Sprawdź w bazie czy masz tą tabele ps_shop_url

*

Offline lukruk

  • Nowy
  • *
  • 13
  • 0
  • Presta Shop: 1.6.1
  • Status: forum
Odp: po aktualizacji błąd 500
« Odpowiedź #12 dnia: Lipiec 19, 2017, 08:30:55 am »
Sprawdź w bazie czy masz tą tabele ps_shop_url

Niestety nie mam takiej pozycji :(

Moja baza wygląda w stylu:
http://darmowegalerie.eu/#/nss/public/596efc5cea65d2222845792d

i nie ma tam pozycji z końcówką url

Jest możliwe że pozycja się sama usunęła ? Wcześniejszy moderator miał jedynie przenieść cała stronę na nowy hosting. Wszystko działało dobrze do momentu jak chciałem wgrać szablon i większe moduły (wczesniejszy hosting miał zabezpieczenie przed wgrywaniem plików powyżej 8mb). Okazało się że nie zostały zmienione DNSy. Po aktualizacji DNSów sklepik się wysypał.

*

Offline endriu107

  • user
  • Mieszkaniec
  • *****
  • 1,080
  • 50
  • Presta Shop: PS
  • Status: forum
Odp: po aktualizacji błąd 500
« Odpowiedź #13 dnia: Lipiec 20, 2017, 02:22:56 pm »
Z tego co widzę to u ciebie tabela powinna sie nazywać

shop_shop_url
Po zmianie DNS-ów sklep chce zaciągnąć dane  z innej bazy, prawdopodobnie lokalnej, ktoś kto ci to robił nie zrobił do końca poprawnie.

*

Offline lukruk

  • Nowy
  • *
  • 13
  • 0
  • Presta Shop: 1.6.1
  • Status: forum
Odp: po aktualizacji błąd 500
« Odpowiedź #14 dnia: Lipiec 20, 2017, 10:10:00 pm »
To co powinienem teraz zrobić aby poprawić ten błąd ?. Jeszcze raz utworzyć bazę danych pod właściwą nazwą ?
Moderator niby zmieniał same DNS. Może baza była wcześniej na wcześniejszym hostingu (o czym nie powiedział, a osobiście też nie sprawdzałem) i po jej nieprawidłowym przeniesieniu wysypało sklep.
Nie przenosiłem jeszcze nigdy sklepu, mógłbyś mi mniej więcej opisać w jaki sposób powinienem naprawić problem z bazą ?