wdrożenia PrestaShop

PrestaShop 1.7 - tłumaczenie

  • 5 Odpowiedzi
  • 749 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline andzelika i jacek

  • Nowy
  • *
  • 10
  • 0
  • Prestashop 1.7
  • Presta Shop: 1.6.1
  • Status: Właściciel
PrestaShop 1.7 - tłumaczenie
« dnia: Grudzień 08, 2016, 01:09:22 am »
Niby sprawa prosta.
Jest:
Popular products
ma być:
Populære produkter
Zmieniłam w tłumaczeniach co pokazuje link:
http://dl.dropbox.com/u/16861891/screenshots/screen161208-010705.png
Jednak na stronie frontowej sklepu po zmianie jest tak:
http://dl.dropbox.com/u/16861891/screenshots/screen161208-010759.png
To język norweski. Niestety źle wyświetla się.
Jak to naprawić?
Czy są jakieś pomysły?

pozdrawiam

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 3,371
  • 85
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: PrestaShop 1.7 - tłumaczenie
« Odpowiedź #1 dnia: Grudzień 08, 2016, 07:52:04 am »
A jakie masz kodowanie bazy danych może brak w tym systemie tych znaków ?
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline andzelika i jacek

  • Nowy
  • *
  • 10
  • 0
  • Prestashop 1.7
  • Presta Shop: 1.6.1
  • Status: Właściciel
Odp: PrestaShop 1.7 - tłumaczenie
« Odpowiedź #2 dnia: Grudzień 08, 2016, 12:24:02 pm »
Sprawdziłam na zapleczu (mam nadzieję, że dobrze)
sytuacja jest poniższa:
http://dl.dropbox.com/u/16861891/screenshots/screen161208-122131.png
Niezależnie które kodowanie zapiszę po odświeżeniu strony "krzaki" są nadal.

*

Offline andzelika i jacek

  • Nowy
  • *
  • 10
  • 0
  • Prestashop 1.7
  • Presta Shop: 1.6.1
  • Status: Właściciel
Odp: PrestaShop 1.7 - tłumaczenie
« Odpowiedź #3 dnia: Grudzień 11, 2016, 12:47:49 pm »
Gdzie mogę ręcznie zmienić na iso-8859-1 , by na stronie sklepu poprawnie wyświetlany był język (j. obcy nie polski)

Zmieniałam w ShopTheme.no-NO.xlf mieszczący się w translations jednak po zmianie z UTF-8 na iso-8859-1 było brak efektu zmiany wyświetlania.

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 3,371
  • 85
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: PrestaShop 1.7 - tłumaczenie
« Odpowiedź #4 dnia: Grudzień 11, 2016, 06:02:30 pm »
w plikach tłumaczeń ale tak jak Ci już mówiłem raczej to wina kodowania bazy danych a tutaj używa się utf-8 lub utf-8mb4
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline andzelika i jacek

  • Nowy
  • *
  • 10
  • 0
  • Prestashop 1.7
  • Presta Shop: 1.6.1
  • Status: Właściciel
Odp: PrestaShop 1.7 - tłumaczenie
« Odpowiedź #5 dnia: Grudzień 13, 2016, 11:11:30 pm »
Witam serdecznie. Dołączam do konta ze wcześniejszymi wpisami żony. Chyba prościej niż zakładać kolejne konto :)
Ponieważ również maczałem palce w stawianiu Prestashop 1.7 postanowiłem poruszyć problem który wyniknął podczas wprowadzania zmian w tłumaczeniach.
Wkleję mój wpis z innego forum.

Wersja 1.7 - no i stało się.
Sklep zbudowany dla klienta.
Doświadczenia moje nie jest porażające :) jednak sklep powstał na razie jako forma katalogu bez płatności.
Wprowadzone zostały produkty wraz z tłumaczeniami na język norweski. Sporo wprowadziłem zmian ponieważ tłumaczenie Presty nie było kompletne, lub było gdzie nie gdzie złe (norweskie) lub wyświetlało się "źle" - kodowanie znaków.

Nagle podczas tłumaczenia na zapleczu jednego z plików strona zrobiła się biała. Być może było to "nagle spowodowane zbyt późnym odświeżeniem się Presty i nie zauważyłem przy jakiej edycji to stało się.
Teraz nie można zalogować się do zaplecza sklepu - brak panelu logowania.
Jednak strona frontowa sklepu działa poprawnie.

przez FTP edytowałem:
config/defines.inc.php
linię:
define('_PS_MODE_DEV_', false);
zaminiłem na:
define('_PS_MODE_DEV_', true);

Efekt tego trybu:
Zaowocowało to tym, że pokazał się panel logowania na zaplecze, po czym bez problemu zalogowałem się i wszystko działało dobrze. Jak zauważyłem i sprawdziłem, wszystko niby działa poprawnie (na zapleczu). Wszystkie wprowadzone dane są.
Po powrocie na false, panelu logowania już nie ma i nie ma jak zalogować się na zaplecze, a strona frontowa sklepu wyświetla się poprawnie..

Sklep dla klienta - front język norweski (bokmål), zaplecze PL.

Grzebałem w plikach i edytowałem braki tłumaczeń na norweski gdzie się da :) starałem się zmienić również UTF-8 na iso-8859-1 ponieważ myślałem że to rozwiąże sprawę z kilkoma błędnie wyświetlanymi norweskimi słowami/znakami. Inne wyświetlały się poprawnie.

Jednak nagle podczas edycji jakiegoś pliku strona zaplecza nagle zrobiła się biała już bez panela logowania. Z nerwów zapomniałem gdzie zmieniałem ale chyba ostatnio byłem w katalogu administracyjnym. Wiem, że przeglądałem/edytowałem jakieś pliki również  .htaccess.
Wspomnę tylko, że nie jest to problem cache przeglądarki Firefox. "Czyściłem" ją itp.

Nie mam pojęcia jak to naprawić. Być może coś nie chcąco usunąłem ze zmęczenia podczas pracy.
Backup mam. Jednak z przed 5 dni - jeszcze przed wprowadzeniem danych do sklepu.

Najciekawsze jest to, że właśnie zamierzałem zmienić ostatni źle wyświetlany wyraz. Było na froncie Norwegia zamiast Norge w inf. o sklepie mimo, że strona frontowa była w bokmål a wyłączony był tryb języka przegladarki. Domyślnie miało być Norweski.

Generalnie powinienem zainstalować klientowi 1.6 i z tłumaczeniami nie miał bym zabawy. Z 1,7 to jakaś porażka we wszystkim nad czym ubolewam jednak teraz nie mam odwrotu..
Ręce mi opadły i nie wiem co robić.

Przepraszam za duży elaborat.
Bardzo proszę o pomoc jak naprawić by wyświetlał się panel logowania.

Podpowiem, że założyłem  hasło/zabezpieczenie na katalog admina i tutaj panel się wyświetla i loguje, jednak dalej bark jest pan. logowania do zaplecza.

Pozdrawiam

P.S.
Raport:
1/1 ContextErrorException in ce908e3af500ef88d0be39d6badc82307b6995cd.module.ps_sharebuttons.tpl.php line 30: Notice: Undefined index: social_share_links

    in ce908e3af500ef88d0be39d6badc82307b6995cd.module.ps_sharebuttons.tpl.php line 30
    at ErrorHandler->handleError('8', 'Undefined index: social_share_links', '/home/nazwa/domains/my_domains/public_html/app/cache/dev/smarty/compile/ce/90/8e/ce908e3af500ef88d0be39d6badc82307b6995cd.module.ps_sharebuttons.tpl.php', '30', array('_smarty_tpl' => object(Smarty_Dev_Template))) in ce908e3af500ef88d0be39d6badc82307b6995cd.module.ps_sharebuttons.tpl.php line 30
    at content_584deb6fcd2350_42737861(object(Smarty_Dev_Template)) in smarty_internal_templatebase.php line 188
    at Smarty_Internal_TemplateBase->fetch(object(Smarty_Dev_Template), null, null, null, false, true, false) in SmartyDev.php line 60
    at Smarty_Dev_Template->fetch() in Module.php line 2271
    at ModuleCore->fetch('module:ps_sharebuttons/views/templates/hook/ps_sharebuttons.tpl') in ps_sharebuttons.php line 132
    at Ps_Sharebuttons->renderWidget('displayFooterBefore', array('smarty' => object(Smarty_Dev_Template), 'cookie' => object(Cookie), 'cart' => object(Cart))) in Hook.php line 763
    at HookCore::coreRenderWidget(object(Ps_Sharebuttons), 'displayFooterBefore', array('smarty' => object(Smarty_Dev_Template), 'cookie' => object(Cookie), 'cart' => object(Cart))) in Hook.php line 737
    at HookCore::exec('displayFooterBefore', array('smarty' => object(Smarty_Dev_Template), 'cookie' => object(Cookie), 'cart' => object(Cart)), null) in smarty.config.inc.php line 170
    at smartyHook(array('h' => 'displayFooterBefore'), object(Smarty_Dev_Template)) in SmartyLazyRegister.php line 83
    at SmartyLazyRegister->__call('smartyHook', array(array('h' => 'displayFooterBefore'), object(Smarty_Dev_Template))) in b2ca3d8474c48fcafe6bdf65e51c918c974955bb.file.index.tpl.php line 531
    at content_584deb6fc0ed94_62358838(object(Smarty_Dev_Template)) in b2ca3d8474c48fcafe6bdf65e51c918c974955bb.file.index.tpl.php line 201
    at content_584deb6fc188f2_11517074(object(Smarty_Dev_Template)) in smarty_internal_templatebase.php line 188
    at Smarty_Internal_TemplateBase->fetch('index.tpl', null, 'layouts/layout-full-width.tpl', object(SmartyDev), false, true, false) in SmartyDev.php line 41
    at SmartyDev->fetch('index.tpl', null, 'layouts/layout-full-width.tpl') in FrontController.php line 655
    at FrontControllerCore->smartyOutputContent('index.tpl') in FrontController.php line 639
    at FrontControllerCore->display() in Controller.php line 221
    at ControllerCore->run() in Dispatcher.php line 366
    at DispatcherCore->dispatch() in index.php line 28
« Ostatnia zmiana: Grudzień 14, 2016, 11:18:25 am wysłana przez west »