wdrożenia PrestaShop Powiększenie zdjęć moduł

Problem z dodawaniem produktów po aktualizacji modułów

  • 2 Odpowiedzi
  • 452 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline hulit

  • Nowy
  • *
  • 2
  • 0
  • PrestaShop
  • Presta Shop: 1.6.1
  • Status: forum
Problem z dodawaniem produktów po aktualizacji modułów
« dnia: Listopad 28, 2016, 11:03:24 am »
Witam serdecznie.

Bardzo proszę o pomoc. Moja presta działała poprawnie i powinienem pewnie postępować w myśl zasady, jak działa, to nie ruszaj.
Niestety coś mnie podkusiło, aby zaktualizować wszystkie moduły, które krzyczały do mnie "aktualizuj!"
Nie napiszę co dokładnie zaktualizowałem, aktualizowałem jak baran, po kolei, jak leci, a było tego pewnie z 70.
Jaki był tego efekt... był, bo historia jest dłuższa niż mogłoby się to wydawać.
Wszystko po aktualizacji działało poprawnie poza dodawaniem produktów.

Edycja istniejącego produktu - po wciśnięciu zapisz i zostań, jak i zapisz panel wyrzucał do strony produktów nie zapisując zmian.
Przy dodawaniu nowego produktu na etapie nazwy i opisów po wciśnięciu zapisz i zostań czyścił wszystkie pola lub wyrzucał do strony z produktami oczywiście nie zapisując nowego produktu.

Doczytałem na forum, że presta nie współpracuje najlepiej z home. Ktoś napisał aby zmienić:
"Włącz przekierowanie na podkatalog z separacją serwisu" na

"Włącz przekierowanie na podkatalog bez separacji serwisu" i ku mojemu zadowoleniu dodałem nowy produkt i edytowałem już istniejące bez problemów... ale tylko wczoraj (27.11), dziś (28.11) problem znów się pojawił.
Te same klocki co przed zmianami przy edycji i dodawaniu produktów.

Nie mając wiele do stracenia, posiadam kopię z 27.11. z ułańską wręcz fantazją zaktualizowałem prestę do najnowszej wersji za pomocą 1-click. (aktualizacja z wersji 1.6.1.1 do 1.6.1.9) Pomyślałem, że część aktualizowanych przeze mnie wcześniej modułów może teraz nie współgrać ze starszą wersją presty. Ku mojemu zdziwieniu dodawanie produktów zaczęło działać tak sprawnie, jak nigdy dotąd, normalnie rewelacja... jednak radość nie trwała długo.

Przy składaniu testowego zamówienia okazało się, że brakuje niektórych grafik, a dokładniej zaznaczania/odhaczania/ptaszka. Przykładowo przy składaniu zamówienia mogłem wybrać opcję dostawy tylko dlatego, że wiem w którym miejscu owo zaznaczenie powinno się znajdować, ale było nie widoczne. Przy rejestracji nowego klienta, nie miałem możliwości wpisania kodu pocztowego - brak pola, a przy próbie zapisania komunikat *pole kod pocztowy jest wymagane.

Wertując forum znalazłem poradę aby w "wydajności" wyczyścić pamięć podręczną i efekt tego jest taki: http://4mum.pl/
nie widzi żadnych obrazków w panelu administracyjnym.
Nie wiem co dalej z tym robić, mam możliwość przywrócenia sklepu do stanu z dnia 27.11. działało składanie zamówień, nie mogłem dodawać i edytować produktów. Bardzo proszę o pomoc w rozwiązaniu problemu.
Na wyświetlanie pomogło, przewertowałem forum i radę znalazłem pod tym linkiem: https://www.prestashop.com/forums/topic/331640-serwer-homepl-problemy-z-prestashop-rozjechany-szablon/
Dziękuję. Testowe zamówienie złożone poprawnie, dodawanie produktów działa.
Teraz inny problem zniknęła część zdjęć. W panelu administracyjnym miniaturki są widoczne w zakładce produkty, natomiast po wejściu w produkt już znaki zapytania. Na stronie wygląda to tak:
http://4mum.pl/12-bluzki-ciazowe?live_configurator_token=3c8221f4dbafe70377ad3b60411dedc3&id_shop=1&id_employee=3&theme=theme8&theme_font=&id_category=12&n=77
Nie chcę więcej kombinować samemu, bo jestem w stosunkowo niezłym punkcie, a bardziej spartolić bym nie chciał. Proszę o pomoc.
« Ostatnia zmiana: Listopad 28, 2016, 11:57:12 am wysłana przez hulit »

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 3,918
  • 96
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: Problem z dodawaniem produktów po aktualizacji modułów
« Odpowiedź #1 dnia: Listopad 28, 2016, 01:32:12 pm »
Pierwszy raz słyszę, aby ktokolwiek odpalał na home skrypt dłuższy niż 30 sekund - one click
Mówiąc wprost szanse powodzenia są zerowe
Musisz moim zdaniem przywrócić kopię sklepu. Ściągnąć sklep na komputer i wtedy wykonać upgrade całości. Następnie wrócić z plikami z powrotem na serwer.
Ostatnio miałem takie zlecenie dla klienta i tylko w taki sposób udało się obejść ograniczenia home. Ponadto korzystałem tylko i wyłącznie z ssh - linii poleceń.
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline hulit

  • Nowy
  • *
  • 2
  • 0
  • PrestaShop
  • Presta Shop: 1.6.1
  • Status: forum
Odp: Problem z dodawaniem produktów po aktualizacji modułów
« Odpowiedź #2 dnia: Listopad 28, 2016, 08:16:41 pm »
Dziękuję za odpowiedź.
Jednak instalacja 1-click się powiodła, jedynie co, to musiałem wprowadzić małe zmiany w: /themes/.htaccess
 /modules/.htaccess
Obecnie wszystko działa prawidłowo. Jedyne co się posypało to zdjęcia (nie wszystkie), nie męczyłem się już z tym, dodałem je ręcznie, nie było tego tragicznie dużo.
Mam dokładnie ten sam problem w drugim sklepie, jak w poście wyżej czyli edytowanie istniejących produktów i dodawanie nowych - problem z zapisem, wyrzuca do strony produktów, cała reszta działa poprawnie.
Może jest jakieś proste rozwiązanie na to, chciałbym uniknąć aktualizacji do wersji 1.6.1.9, zależy mi tylko na rozwiązaniu tego problemu.  Na około już wiem jak to zrobić, ale trochę zamieszania z tym było i zawsze może się coś posypać, bo jak pisałeś na upgrade 1-click na home szanse prawie zerowe, więc możliwe, że tu był to jakiś łud szczęścia i przy upgrade na drugim sklepie coś się posypie.