wdrożenia PrestaShop Powiększenie zdjęć moduł wdrożenia PrestaShop

1.6.0.5 nie wyświetla się prawidłowo frontofice

  • 6 Odpowiedzi
  • 2548 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline loczek

  • Nowy
  • *
  • 14
  • 0
1.6.0.5 nie wyświetla się prawidłowo frontofice
« dnia: Marzec 20, 2014, 12:18:24 pm »
Tak sobie testuje ten sklep i na localu działał a po instalacji na serwerze ( testowo na razie )

działa tak :

http://sklep.sunnyeco.pl/batest/

instalowałem ze 3 razy i dalej to samo , co mogłem źle zrobić ?

back office wyświetla się prawidłowo .


*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 4,915
  • 100
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: 1.6.0.5 nie wyświetla się prawidłowo frontofice
« Odpowiedź #1 dnia: Marzec 20, 2014, 12:39:40 pm »
wygeneruj ponownie htaccess
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline loczek

  • Nowy
  • *
  • 14
  • 0
Odp: 1.6.0.5 nie wyświetla się prawidłowo frontofice
« Odpowiedź #2 dnia: Marzec 20, 2014, 01:16:02 pm »
Jeżeli generuje się jak w 1.5 to nic to nie dało

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 4,915
  • 100
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: 1.6.0.5 nie wyświetla się prawidłowo frontofice
« Odpowiedź #3 dnia: Marzec 20, 2014, 01:40:37 pm »
sprawdź urle seo & url ewidentnie masz powaloną ścieżkę do sklepu / tematu
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline mariuszpn

  • Nowy
  • *
  • 10
  • 0
Odp: 1.6.0.5 nie wyświetla się prawidłowo frontofice
« Odpowiedź #4 dnia: Kwiecień 01, 2014, 02:52:27 pm »
mam ten sam problem zrobiłem co pisał west ale jest to samo. Co zrobic możecie jakoś pomóc ?

*

Offline mariuszpn

  • Nowy
  • *
  • 10
  • 0
Odp: 1.6.0.5 nie wyświetla się prawidłowo frontofice
« Odpowiedź #5 dnia: Kwiecień 02, 2014, 09:13:18 am »
Jeśli jeszcze ktoś miałby ten problem to poniżej rozwiązanie może się komuś przyda:

Przyczyną jest użycie nieobsługiwanej przez niektóre serwery dyrektywy FilesMatch w plikach htaccess aplikacji.
W przypadku IdeaWebServer dyrektywa FilesMatch nie jest obsługiwana, więc korzystamy z Files.

Przykład zablokowania dostępu do wszystkich plików z wyłączeniem jpg|gif|png:

<Files ~ "\.*">
Order allow,deny
Deny from all
</Files>

AllowOverride All
<Files ~ "\.(jpg|gif|png)">
Order allow,deny
Allow from all
</Files>

Proszę poprawić dwa pliki .htaccess:
/themes/.htaccess
/modules/.htaccess

I zamienić w nich treść:
<FilesMatch "\.tpl$">
Deny from all
</FilesMatch>

na:
<Files ~ "\.tpl$">
Deny from all
</Files>


Pozdrawiam

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 4,915
  • 100
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: 1.6.0.5 nie wyświetla się prawidłowo frontofice
« Odpowiedź #6 dnia: Kwiecień 02, 2014, 10:08:06 am »
czyli należy zamiast filesmatch zastosować zmienną files w plikach htaccess w katalogach modules i themes - problem dotyczy home i kilku innych cudownych rozwiązań hostingowych. Skasowanie tych plików powoduje poważne naruszenie bezpieczeństwa sklepu.
p.s. niepełne pytanie powoduje błędne odpowiedzi - trzeba było podać hosting ........
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz